Accessing Flyertalk with Chrome

Old Nov 16, 18, 10:03 am
  #1  
Original Poster
 
Join Date: Jul 2013
Posts: 5,207
Accessing Flyertalk with Chrome

I've recently had trouble accessing flyertalk with Chrome

I get the following error

This site canít provide a secure connection

www.flyertalk.com uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH
Hide details
The client and server don't support a common SSL protocol version or cipher suite. This is likely to be caused when the server needs RC4, which is no longer considered secure

version Version 49.0.2623.112 unknown-m
rsteinmetz70112 is online now  
Old Nov 16, 18, 10:33 am
  #2  
Administrator
 
Join Date: Sep 2015
Programs: Internet Brands
Posts: 1,782
Hi Steinmetz,

I almost exclusively use Chrome and have no problems. There may have been some minor site maintenance. How long has this been happening for you?
IBJoel is offline  

Thread Tools
Search this Thread