Go Back  FlyerTalk Forums > Miles&Points > Airlines and Mileage Programs > United Airlines | MileagePlus
Reload this Page >

UA app on Android - no longer supported? (for older Android systems - 4.x or pre 7.x)

UA app on Android - no longer supported? (for older Android systems - 4.x or pre 7.x)

Old Aug 26, 20, 9:07 am
  #1  
Original Poster
 
Join Date: Mar 2008
Location: Austin (TX)
Posts: 308
UA app on Android - no longer supported? (for older Android systems - 4.x or pre 7.x)

I apologize in advance if this was addressed elsewhere, but I had no luck finding anything on the problem...

I had yet another flight this past week and went to check in using the app on a phone running Android. I got through the splash screen and then the message that I needed to update the app. After clicking through and the little download bar trying to do its thing...no joy.

If I go to search United app, I got brought to the Google Play store telling me the app was no longer supported on my device. Looking through the United site, the closest thing to information was a link for someone to use if they were running one of the 4.x versions of Android. Nothing else that I could locate related to problems with the app for later versions, although the reviews on the Google Play site seemed to suggest MANY have had problems within the past few weeks.

App worked fine when I flew to LAS a few weeks ago. Return trip to LAS is where the problems were discovered

I sent an email to the contact on the app page which got me the following reply:

Hi Michelle,


Thanks for reaching out to us.

We've been advised by Google Play that they no longer support our App. We apologize for any Inconvenience.

Thank you for your loyalty with United. We appreciate your business.


Regards,

Asra
Customer Care
Case ID: 1598290211xyza /partially redacted/::: ORIGINAL EMAIL :::

From: /my email addy/

Message:Hi team,
Good morning, can someone reach out to this person to advise the device is no longer supported. We were advised by Google Play it will no longer be supported to we were forced to change our app. The issue is with Google Play, not United,.



Thanks,
Robyn
Can someone else with Android (or that works with United) confirm that this crock of warmed over bovine excrement is accurate? Did United really decide that the Android users are no longer worthy of online check-in OR the in-flight entertainment?

And no...getting an iPhone is NOT a viable resolution.
michelle227 is offline  
Old Aug 26, 20, 9:17 am
  #2  
 
Join Date: Oct 2013
Location: KEWR
Programs: UA 1K, HH Diamond, SPG/Marriott Gold, Hyatt Plat, National Exec, GE/Nexus
Posts: 455
Sometimes the operating system of the device is not able to support the app. I've had it happen on really old devices - the app doesn't appear in Google Play at all. On my newer devices it's there. I see the app available on my device.
miasmal is offline  
Old Aug 26, 20, 9:31 am
  #3  
Original Poster
 
Join Date: Mar 2008
Location: Austin (TX)
Posts: 308
Except, after having provided them with the OS, they are not saying it is the OS. They are saying it is a Google Play issue.
michelle227 is offline  
Old Aug 26, 20, 9:32 am
  #4  
 
Join Date: Mar 2016
Location: Houston/DC
Programs: UA 1K
Posts: 537
How old is your device? It is very possible that the apps won't be supported on a phones operating system if the device is too old.

For example, I have an old Samsung S4 that I keep in my pack as a backup in case my main phone goes down & needs to be serviced. I think that device might be in the same boat as yours in regards to not working with newer versions of certain apps.
FlyngSvyr is offline  
Old Aug 26, 20, 9:57 am
  #5  
FlyerTalk Evangelist
 
Join Date: Sep 2003
Posts: 10,890
Originally Posted by FlyngSvyr View Post
...I have an old Samsung S4 that I keep in my pack as a backup in case my main phone goes down & needs to be serviced...
Keeping an old phone as a spare is a very smart move. My 11 went on the fritz a couple of weeks ago the day of a flight to mainland. Local Apple tech said it had to go to mainland for two weeks for servicing. I swapped SIM to my previous phone (6, I don't update frequently ) and was off and running. UA app works on 6 and all my data showed up, and, for some reason I don't understand, probably a hundred contacts I didn't recognize. Handy for return because quarantine officials want to check the number you give them on arrival back to Hawaii.

I've never felt as lost as when my phone went inoperative. It's like a vital organ nowadays
IAH-OIL-TRASH is offline  
Old Aug 26, 20, 9:58 am
  #6  
Moderator: United Airlines; FlyerTalk Evangelist
 
Join Date: Jun 2007
Location: SFO
Programs: UA Plat 1.85MM, Hyatt Discoverist, Marriott Plat/LT Gold, Hilton Silver, IHG Gold
Posts: 53,623
The
 Andriod App is still available Andriod App is still available
working and updating fine for me but not for older devices
Minimum Operating System: Android 7.0
Same statement on Google Play

How old is your device?
Appears if you are running Andriod 4, your device / phone manufacture is not longer updating / supporting your phone. What model is it?

Understand this is disappointing but it happens. I was disappointed when UA stopped supporting Amazon Fire devices.

Note similiar limitations for IOS devices
Requires iOS 11.0 and watchOS 2.0 or later. Compatible with iPhone, iPad, and iPod touch.
ajGoes and st3 like this.

Last edited by WineCountryUA; Aug 26, 20 at 10:06 am Reason: IOS
WineCountryUA is offline  
Old Aug 26, 20, 10:03 am
  #7  
 
Join Date: Jul 2008
Location: home since March
Programs: BA Meltdown soft-landed Silver, OZ♦+ (BR/UA), B6 Mosaic, WoH♦, Mlife Noir, TR 7*
Posts: 5,729
Originally Posted by michelle227 View Post
Except, after having provided them with the OS, they are not saying it is the OS. They are saying it is a Google Play issue.
Just to be clear, that's not what was actually stated in the e-mail response. The language used is very poor, to be fair, but it does not exclude the OS/device compatability being the issue.
gengar is offline  
Old Aug 26, 20, 10:16 am
  #8  
Moderator: United Airlines; FlyerTalk Evangelist
 
Join Date: Jun 2007
Location: SFO
Programs: UA Plat 1.85MM, Hyatt Discoverist, Marriott Plat/LT Gold, Hilton Silver, IHG Gold
Posts: 53,623
Originally Posted by gengar View Post
Just to be clear, that's not what was actually stated in the e-mail response. The language used is very poor, to be fair, but it does not exclude the OS/device compatibility being the issue.
Correct, Google Play is smart enough not to offer an app for which the device is not compatible. So it is correct Google Play does not offer the app due to incompatible OS.

But agree the explanation could have been better.

Believe on Amazon, the device is flagged as incompatible but the app is listed.
WineCountryUA is offline  
Old Aug 26, 20, 11:14 am
  #9  
 
Join Date: May 2003
Location: Cleveland, OH
Programs: UA-GS 1MM), Hertz Pres Circle, Starriott Titanium)
Posts: 1,845
Lack of updates after 1-2 years is my biggest gripe with most Android OEMs. I use a Google Pixel specifically because it will have a longer update lifespan typically. I don't think it is reasonable to expect United or other companies to keep supporting ancient operating systems on un-updated phones. Android 4 came out in 2011. https://en.wikipedia.org/wiki/Androi...Cream_Sandwich

I think it might be time to update the phone, meantime, you could use the webapp I suppose.
ajGoes likes this.
LordHamster is offline  
Old Aug 26, 20, 11:59 am
  #10  
 
Join Date: Feb 2002
Location: BNA
Programs: HH Gold. (Former) UA PP, DL PM, PC Plat
Posts: 6,967
Originally Posted by LordHamster View Post
I use a Google Pixel specifically because it will have a longer update lifespan typically.
Yes! And you don't have all the junk that the phone manufacturers and carriers add.

I started with Google phones with the Nexus 5X and later moved to the Pixel 2. Haven't upgraded yet as the Pixel 2 is still one of the first phones to get the upgrade to the latest versions of Android.
bchandler02 and ajGoes like this.
LarryJ is offline  
Old Aug 26, 20, 12:06 pm
  #11  
 
Join Date: Aug 2020
Location: SFO
Programs: Many
Posts: 116
I believe United could have worded their response better, but the fact remains that every software/hardware does have a life cycle after which itís no longer supported. Itís neither a Google Play issue nor a United issue and more of a device issue.
ajGoes and st3 like this.
dsftm is offline  
Old Aug 26, 20, 12:17 pm
  #12  
 
Join Date: Sep 2013
Location: CHS
Programs: UA GS, Bonvoy Amabassador, Hertz PC
Posts: 2,259
The same thing happens on iOS, my iPad ver 2 from 2011 just stopped being supported as well. That was an Apple didn't allow the last iOS update and therefore the newest UA app was not allowed.

Not really complaining about a 9year old device though - Apple tends to support much older equipment for much longer - but it still happens just the same as Android.
Hipplewm is offline  
Old Aug 26, 20, 12:34 pm
  #13  
 
Join Date: Jan 2009
Location: OKC
Programs: IHG Spire, National Exec, AA Plat
Posts: 1,732
If you're running something with Android 4.x on it, you severely need an upgrade. That is a major security risk.

People do not put enough focus on keeping a reasonably updated phone/computer from a security perspective.
ajGoes likes this.
bchandler02 is offline  
Old Aug 26, 20, 2:17 pm
  #14  
 
Join Date: Jul 2018
Posts: 18
If you are running Android 4.x then wow thats is a phone OS that's last updated release was 8 years ago, which is ancient by phone OS standards

Get a new phone my goodness.... You're at a major security risk and you cant expect developers to maintain a app for a OS that is no longer supported, and on less than 2% of currently used devices.
ajGoes likes this.
PreMerger is offline  
Old Aug 27, 20, 8:54 am
  #15  
Original Poster
 
Join Date: Mar 2008
Location: Austin (TX)
Posts: 308
I don't have a 4.x version of Android. I noted the link on the United site for the point of reference. There is STILL a page on the United site to download a version of the app for THAT version of Android though.

They were provided with the information about the version I was running, which according to this thread SHOULD be supported. They have doubled down on their claims through Twitter. Some of us DO keep phones for more than a few months. Not all of us live on them and some of us use a desktop for things that actually require some manner of uber-secure environment. The app worked FINE on my trip to LAS in July. Less than three weeks later, and without notice, it ceased to function and United is laying ALL of the blame squarely at the feet of Google Play. At least when MicroSoft decides not to support something, notice is given that they were not going to provide updates...however, the software generally continues to function.

They have made a decision to shove a number of passengers to OTHER carriers, especially now that so many of the planes have ceased to offer the DirecTV option and pax are left only with the onboard IFE (useless to begin with for all intents and purposes). I guess Kirby figures that pissing off those who actually are willing to fly right now is a good way to justify his furloughs that will be coming...

And no, I am not replacing a three-year old phone so that I can run one single app.
michelle227 is offline  

Thread Tools
Search this Thread
Search Engine: