Unable to book Forward Y seat

Old Jul 14, 19, 9:56 am
  #1  
FlyerTalk Evangelist
Original Poster
 
Join Date: Sep 1999
Location: Toronto, Ontario, Canada
Programs: OWEmerald; STARGold; SPGPlat; PCPlat/Amb; HiltonDiamond; CarlsonGold; A|ClubPat; AirMilesGold
Posts: 38,054
Unable to book Forward Y seat

I've now tried twice to book a forward economy seat on my SQ flight between SIN-SGN in October. Both times, after my credit card charge showed up on my iPhone immediately after doing the payment, I get a screen on the SQ website indicating there will be a delay in processing and confirming my purchase. A day later, the cc pending charge has vanished, no charge appears, and on checking the SQ site, no seat has been booked.

Some further specifics: this is an award ticket using UA/MP miles and the FF number on the booking is my AC/Altitude number (STARGold).

Is this a common experience for non-singapore resident credit cards?
Shareholder is offline  
Old Jul 17, 19, 5:51 pm
  #2  
 
Join Date: Jan 2019
Posts: 23
Happened to me recently when using an Amex card - it failed to process the safekey step and the payment never went through. SIA showed the seat selection for a day or so, then it dropped off. So I retried with a Mastercard and it worked fine. Try a different card, and perhaps also using a proper browser on a PC/laptop.
stmaus is offline  

Thread Tools
Search this Thread