CitiBusiness AAdvantage Miles Not Posted

Old Apr 3, 2024, 11:27 am
  #1  
Original Poster
 
Join Date: Dec 2005
Posts: 5
CitiBusiness AAdvantage Miles Not Posted

I recently applied for CitiBusiness AAdvantage Business card. Promotion miles 65000 once the spending threshold is achieved.

I reached the spending threshold within the first month. The statement closed on 3/26/2024 and the Citibank statement shows the 65000 bonus miles as well as the spending miles accrued in March. It has been over a week but the credit has not posted to my AA account. I have talked to Citibank and they are not of much help. They are indicating that the miles will post with the next statement, which I know is not true.

Does anyone has experience with this? How long before the bonus miles are posted?
raxbab is offline  
Old Apr 3, 2024, 11:40 am
  #2  
PHL
FlyerTalk Evangelist
 
Join Date: Dec 2000
Location: PHL, NYC
Programs: AA PLT, DL SLV, UA SLV, MR LTT, HH DIA
Posts: 10,060
https://creditcards.aa.com/cbaa_standard/

American Airlines AAdvantage® bonus miles typically will appear as a bonus in your AAdvantage Business™ account 8-10 weeks after you have met the purchase requirement
Antarius likes this.
PHL is offline  
Old Apr 3, 2024, 5:44 pm
  #3  
 
Join Date: May 2000
Location: Houston, TX, USA
Programs: UA 1K, AA Lifetime Platinum, DL Platinum, Honors Diamond, Bonvoy Titanium, Hertz Platinum
Posts: 7,969
Originally Posted by raxbab
It has been over a week but the credit has not posted to my AA account.
Did only the bonus not post to your AA account, or were the regular miles for spend also not posted? If neither posted, then consider the possibility that a new AA account that you don't know about got created and the miles posted there. That's what happens if your existing AA account isn't properly linked to the credit card application, as they think you're a new customer. If this is the case, call Citibank and confirm the AA account they have on file.
Steve M is offline  
Old Apr 3, 2024, 6:39 pm
  #4  
 
Join Date: Sep 2009
Programs: AA Executive Platinum, Marriott Lifetime Titanium, IHG Platinum
Posts: 1,425
Originally Posted by raxbab
I recently applied for CitiBusiness AAdvantage Business card. Promotion miles 65000 once the spending threshold is achieved.

I reached the spending threshold within the first month. The statement closed on 3/26/2024 and the Citibank statement shows the 65000 bonus miles as well as the spending miles accrued in March. It has been over a week but the credit has not posted to my AA account. I have talked to Citibank and they are not of much help. They are indicating that the miles will post with the next statement, which I know is not true.

Does anyone has experience with this? How long before the bonus miles are posted?
AA implemented a prorating so that charges made in Feb count towards last years qualification year, and March charges count towards this qualification year. As far as I know, nobody has received points for March, even though their closing dates were in March (myself included). The advice given by AA is that they will post next month. Maybe this is what you are seeing as well.
WannaTheater is online now  
Old Apr 4, 2024, 7:51 am
  #5  
FlyerTalk Evangelist
 
Join Date: Aug 2012
Location: KHOU/KIAH
Programs: AA EXP | Marriott Bonvoy Titanium| Hyatt Globalist
Posts: 11,214
To confirm, it hasn't posted to the AA Business account?

I recently opened the Citi Business card and hit the spend within a couple of days. Didn't see anything and then I realized it had (correctly) posted to the business account.


What i cannot find is any activity ledger. I just have this block of miles with zero backing to it.
Antarius is online now  
Old Apr 6, 2024, 7:09 am
  #6  
Original Poster
 
Join Date: Dec 2005
Posts: 5
I realized that my miles were posted to the Business account as well, similar to yours. I was able to successfully transfer these to my personal account -- no problem.

This is where the problem started. The loyalty points do not show anywhere in the Business account and no LPs were transferred/posted to my personal account when I did the transfer.

I have called, e-mailed, chatted with AA Customer Service multiple times and I am given a run around with every agent telling me something different.

One said that March LPs have not posted yet, which I know is not completely true as my wife received her March LPs posted on April 1.
raxbab is offline  

Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

This site is owned, operated, and maintained by MH Sub I, LLC dba Internet Brands. Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Designated trademarks are the property of their respective owners.