Go Back   FlyerTalk Forums > Miles&Points > Credit, Debit and Prepaid Card Programs > American Express | Membership Rewards
Sign in using an external account

Reply
 
Thread Tools Search this Thread
Old Jul 21, 05, 12:38 pm   #1
 
Join Date: Apr 2002
Location: LAX, BUR
Programs: AA, DL, HH, NW, UA, SPG
Posts: 160
AMEX denies admin fee, tax, and loss of use on rental coverage. help requested

I just made a claim with the starwood card.
AMEX did not pay sales tax (unless required by law; I am in CA), administration fee, or loss of use. All of these exclusions are in their contract.

Looking through a few VISA and MC contracts, most of them do not have these exclusions except occasionally for tax.

I expected AMEX to best VISA.

Is the renter legally responsible for items like administration fee? In my case 150. The company also fixed preexisting damage on hubcap . The total unpaid amount is around 500.

Last edited by slow; Jul 21, 05 at 12:40 pm.
slow is offline   Reply With Quote
Old Jul 21, 05, 1:47 pm   #2
 
Join Date: May 2004
Location: Oakland, CA (SFO/OAK)
Programs: UA 1K MM
Posts: 2,282
anyone have success getting the $150 admin fee paid for?
amartin1979 is offline   Reply With Quote
Old Jul 22, 05, 4:43 pm   #3
 
Join Date: Jan 2005
Location: Houston, TX
Programs: Continental Silver Elite, *wood Gold, HHonors Gold, WN
Posts: 86
There have been a few threads on this in the past couple weeks--do a search for "insurance" in this forum. I think (but can't promise) a few people suggested talking to AmEx as they often deal with this situation and might be able to exert some pressure on the rental company to reduce or eliminate fees.
Fly2005 is offline   Reply With Quote
Old Jul 24, 05, 2:22 pm   #4
Original Member
 
Join Date: May 1998
Location: Kirkland, WA
Posts: 6,925
When they did that in my case, Avis was happy with what AmEx paid them and considered the case closed.

QL
__________________
www.liontales.com
QuietLion is offline   Reply With Quote
Old Jul 24, 05, 7:44 pm   #5
Moderator: Luxury Hotels and FlyerTalk Evangelist
 
Join Date: Sep 2002
Location: Palo Alto, California,USA
Posts: 14,488
When Amex used to pay for loss of use, and it was requested, they asked for proof that the company was at least 80% booked to establish that they WOULD have otherwise rented the car. You might try doing the same to contest that charge, at least.
RichardInSF is offline   Reply With Quote
Old Jul 24, 05, 8:11 pm   #6
 
Join Date: May 2004
Location: Oakland, CA (SFO/OAK)
Programs: UA 1K MM
Posts: 2,282
I also got a letter from AMEX telling me my $150 admin fee was declined. They said they needed documentation from Enterprise to pay it. I never received a bill from Enterprise asking for the $150, so I havent followed up on it. If Enterprise does not see fit to bill me for the Admin fee, is the case closed?
amartin1979 is offline   Reply With Quote
Old Jul 25, 05, 9:39 pm   #7
 
Join Date: Jun 2004
Programs: BD, DL, UA, AA, Marriott, SPG
Posts: 873
Quote:
Originally Posted by QuietLion
When they did that in my case, Avis was happy with what AmEx paid them and considered the case closed.

QL
Amex settled with Enterprise and I didn't have to pay anything, but I'm not sure Enterprise was happy with what they were paid. They will now never rent to me again!
piyush is offline   Reply With Quote
Old Jul 26, 05, 3:03 pm   #8
 
Join Date: Apr 2005
Location: PHX
Programs: US Airways Silver
Posts: 3,787
Quote:
Originally Posted by piyush
Amex settled with Enterprise and I didn't have to pay anything, but I'm not sure Enterprise was happy with what they were paid. They will now never rent to me again!
So you had the best possible outcome. Seriously, Enterprise and Alamo are on my "never use" list due to problems I've had renting from them. I don't care how much cheaper they are, it's not worth it.
alanh is offline   Reply With Quote
Old Jul 27, 05, 9:23 am   #9
 
Join Date: Jan 2005
Location: Houston, TX
Programs: UA 1K, HHonors Diamond, SPG Plat
Posts: 63
Quote:
Originally Posted by piyush
Amex settled with Enterprise and I didn't have to pay anything, but I'm not sure Enterprise was happy with what they were paid. They will now never rent to me again!
Consider that a good thing. Enterprise is horrible.
owie69 is offline   Reply With Quote
 
 
Reply

Bookmarks


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off
Forum Jump


All times are GMT -6. The time now is 5:20 am.